Zur Suche springen Zur Navigation springen Zum Hauptinhalt springen Zum Footer springen

Wenn ihr HTML5 und CSS3 in aktuellen Projekten einsetzen möchtet, stellt sich häufig folgende Frage: In welchem Browser wird Funktion X oder Eigenschaft Y denn nun eigentlich schon unterstützt? Genau das ist ein Kernproblem bei der Nutzung der modernen Techniken und führt zu einiger Verunsicherung. Damit ihr die zukünftigen Standards ohne Kompatibilitätsprobleme verwenden könnt, solltet ihr unbedingt einen Blick auf die Website „Can I Use“ werfen. Über eine Suchmaske könnt ihr nach HTML5-, CSS3- und SVG-Befehlen suchen und erhaltet als Ergebnis eine detaillierte Auflistung über die jeweilige Browser-Kompatibilität. Absolute Praxisempfehlung.

Schulungen von kulturbanause

Intensive Trainings mit hohem Praxisbezug. Z. B.: Coding for Designers oder Seminar: CSS für Webanwendungen

HTML5 und CSS3 bereits heute nutzen: Can I Use ... ?

Geschrieben von Jonas

thumb

Jonas ist Gründer der Webdesign Agentur kulturbanause® und des kulturbanause® Blogs. Er übernimmt Projektleitung, Grafik sowie Frontend- und WordPress-Development und hat zahlreiche Fachbücher und Video-Trainings veröffentlicht. Als Dozent leitet er Schulungen und Workshops. Am liebsten beschäftigt er sich mit Projekten und Themen, die ihn gleichermaßen konzeptionell als auch gestalterisch und technisch fordern.

Seminare mit Jonas Hellwig anzeigenJonas Hellwig bei Xing

Feedback & Ergänzungen – 3 Kommentare

  1. Horst Grunwald
    schrieb am 14.09.2011 um 16:37 Uhr:

    Hey Jonas,
    kannte schon das ein oder andere Verzeichnis, aber die SuFu ist klasse. Jetzt aber mal eine Praxisfrage: Wie handhabst du denn den Code von einer Website? Schließlich nutzen bestimmt noch viele IE8 oder gar 7 und selbst der IE9 weist auch noch roße Schwächen auf. Schreibst du für solche Browser extra noch mal eine eigene CSS-Datei und hinterlegst die Grafiken, die du heute mit CSS 3 schon gestalten kannst, noch mal auf dem Server und rufst sie dann dementsprechenden in den CSS-Dateien für ältere Browser auf?
    Dann hätte man ja irgendwo zwar nicht die doppelte Arbeit, aber doch ein gutes Stück mehr Arbeit oder? Umgehst du das irgendwie oder muss man in diese Zitrone beißen?

    Gruß,
    Horst

    Antworten
    • Jonas Hellwig (Autor)
      schrieb am 15.09.2011 um 07:47 Uhr:

      @Horst: Ich berücksichtige bis zum IE7 alle Internet Explorer Versionen. Der 6er nur wenn es ausdrücklich gewünscht ist oder die Zielgruppe sehr speziell ist. Technisch löse ich das alles in einer CSS-Datei um HTTP-Requests einzusparen. Im HTML schreibe ich dafür Conditional Comments um den öffnenden html-Tag. So vergebe ich auf oberster Ebene eine IE-spezifische Klasse und kann anschließend im CSS-Code ganz einfach jedes Elemente für jeden IE gezielt ansprechen.

      <!--[if IE 6 ]> <html lang="DE-de" class="ie6"> <![endif]-->
      <!--[if IE 7 ]> <html lang="DE-de" class="ie7"> <![endif]-->
      <!--[if IE 8 ]> <html lang="DE-de" class="ie8"> <![endif]-->
      <!--[if IE 9 ]> <html lang="DE-de" class="ie9"> <![endif]-->
      <!--[if (gt IE 9)|!(IE)]><!--> <html lang="DE-de"> <!--<![endif]-->

      Antworten
  2. chaoskoeppsche
    schrieb am 14.09.2011 um 08:14 Uhr:

    Vielen Dank für den Tipp! Auch klasse ist http://haz.io/ – dort einfach mit dem jew. Browser drauf und es wird einem angezeigt, was er so kann. :o)

    Antworten

Schreibe einen Kommentar zu chaoskoeppsche Antworten abbrechen

Wir freuen uns über Anregungen, Ergänzungen oder Hinweise zu Fehlern. Wir lesen jeden Eintrag, veröffentlichen aber nur, was den Inhalt sinnvoll ergänzt.

Website-Projekte mit kulturbanause

Wir wissen wovon wir reden. Wir realisieren komplette Projekte oder unterstützen punktuell in den Bereichen Design, Development, Strategy und Content.

Übersicht Kompetenzen →

Schulungen von kulturbanause

Wir bieten Seminare und Workshops zu den Themen Konzept, Design und Development. Immer up-to-date, praxisnah, kurzweilig und mit dem notwendigen Blick über den Tellerrand.

Übersicht Schulungsthemen →